Configuración Básica de HSRP

Hace algún tiempo mi amigo se vio en la necesidad de implementar una solución la cual debería de brindar alta disponibilidad a la LAN, analizando su necesidad, en mi mente se presentaron dos opciones:

  1. HSRP.
  2. IGP.

En este post veremos la funcionalidad de HSRP conocido como Host Standby Routing Protocol. El protocolo (HSRP) es un estándar de Cisco que proporciona redundancia a una red LAN con una default gateway común. Permite que un grupo de interfaces de diferentes routers trabajen en conjunto para aparentar ser un solo router virtual.

Un solo router es elegido del grupo como responsable del reenvío de los paquetes que los hosts envían al router virtual. Este router se conoce como router activo. Otro router se elige como router de backup o standby. Si el router activo falla, el router standby asume los deberes de reenvío de paquetes. Aunque un número arbitrario de routers puede ejecutar HSRP, sólo el router activo es el encargado de realizar la tarea de forwarding de los paquetes provenientes de la red Lan.

Los routers que ejecutan HSRP comunican la información HSRP a través de paquetes hello. Estos paquetes se envían a la dirección de destino multicast IP 224.0.0.2 en el puerto 1985 UDP.

El router activo envía los paquetes de HSRP a través de la dirección ip configurada en la interface y con la dirección MAC virtual.

La dirección MAC virtual esta compuesta por el prefijo 0000.0c07.ac @@ donde @@ representa el numero de grupo en un valor hexadecimal. La siguiente tabla muestra los valores en hexadecimal, binario y decimal. Por ejemplo si el grupo de HSRP es el numero 1 la dirección MAC 0000.0c07.ac01.

Veamos el siguiente ejemplo.

En el siguiente diagrama se ejemplifica uno de los escenarios que podemos encontrar hoy en día en alguna empresa. Sé que el escenario de alta disponibilidad de la WAN no es el mejor y que probablemente tampoco sea común encontrarlo, sin embargo les pido dejarlo pasar por alto ya que es el motivo de este post es mostrar la configuración del protocolo HSRP sin entrar en mayores detalles técnicos.

Lo primero que configuraremos serán las interfaces WAN de ambos routers CPEs y provarmeos la conectividad hacia el router de Internet (PE).

ISP.

interface Serial0/0
ip address 200.200.200.1 255.255.255.252
no shut
!
interface Serial0/1
ip address 201.201.201.1 255.255.255.252
no shut

Router Active.

interface Serial0/0
ip address 200.200.200.2 255.255.255.252
no shut
¡
Active#ping 200.200.200.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.200.200.1, timeout is 2 seconds:
!!!!!

Router Standby.

interface Serial0/0
ip address 201.201.201.2 255.255.255.252
no shut
!
Standby#ping 201.201.201.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 201.201.201.1, timeout is 2 seconds:
!!!!!

Una vez que hemos comprobado la conectividad de ambos routers con el ISP es tiempo de configurar las interfaces LAN de ambos equipos.

El direccionamiento que se utiliza en este ejemplo es el segmento de red 192.168.1.0/24 en donde las siguientes direcciones son utilizadas por el proceso de HSRP.

192.168.1.252 <— Interfaz física FastEthernet 0/0 del Router Activo.

192.168.1.253 <— Interfaz física FastEthernet 0/0 del Router Stanby.

192.168.1.254 <—-Interfaz virtual.

El grupo de HSRP que configuraremos será el numero 10 siendo este un número al azar entre los grupos permitidos por HSRP v1 (0-255).

La configuración de los puertos FastEthernet es la siguiente:

Router Active

interface FastEthernet0/0
ip address 192.168.1.252 255.255.255.0
duplex full
speed 100
standby 10 ip 192.168.1.254 <——— Este comando indica el numero del grupo de HSRP y la dirección virtual que se utilizará
standby 10 preempt <——— Este comando permite que en caso de que el router active regresé depúes de una falla pueda tomar de nuevo el rol de equipo principal.

Router Standby

interface FastEthernet0/0
 ip address 192.168.1.253 255.255.255.0
duplex full
 speed 100
 standby 10 ip 192.168.1.254 <——— Este comando indica el numero del grupo de HSRP y la dirección virtual que se utilizará
 standby 10 priority 95 <——— Este comando especifica el valor de la prioridad.

Para poder seleccionar un router cómo activo o principal, es necesario configurar las prioridades, por defecto si no se especifica alguna prioridad el valor será de 100.

En este ejemplo en el router que actúa como respaldo tiene una prioridad de 95, el motivo del por qué se elige este valor es debido a que cada vez que existe una caída en el router principal esté decrementara su prioridad en bloques de 10, es decir, si el equipo activo fallará el valor de su prioridad cambiaría de 100 a 90, el equipo secundario al tener una prioridad de 95 y al ser mayor que 90 tomaría el papel de equipo activo.

Es importante recordar este punto del decremento ya que en algunas experiencias de colaboradores de trabajo HSRP no funciona por qué al equipo que funge como respaldo se ha configurado con una prioridad muy baja y aun cuando el equipo principal tenga una falla y está falla haga el decremento del equipo activo, la prioridad del equipo de respaldo no supera la prioridad del equipo activo.

Un ejemplo de lo arriba mencionado sería que el equipo de respaldo tuviera configurar una prioridad de 70.

Para revisar el estado de HSRP se puede utilizar el comando show standby brief

Active#show standby brief 
P indicates configured to preempt.
Interface   Grp Prio P State    Active          Standby         Virtual IP     
Fa0/0       10  100  P Active   local           192.168.1.253   192.168.1.254  

El output del comando nos arroja la siguiente información:

  • Grupo: Indica el numero de grupo de Standby.
  • Prioridad: Indica el valor de la prioridad.
  • P: Indica si la función de Preempt se encuentra habilitada.
  • Estate: Indica el estado actual del equipo en el proceso de HSRP.
  • Active: Indica quien es el equipo que actúa como equipos principal en el proceso de HSRP.
  • Standy: Indica la dirección del equipos que actua como equipos de respaldo.
  • Virtual IP: Indica la dirección ip virtual del grupo de HSRP.

Aquí se muestra el mismo output del comando show standby brinde del equipo Standby.

Standby#show standby brief 
P indicates configured to preempt.
Interface   Grp Prio P State    Active          Standby         Virtual IP     
Fa0/0       10  95     Standby  192.168.1.252   local           192.168.1.254  

Esta ejemplo muestra la configuración básica necesaria para hacer funcionar HSRP.

El switch Core contiene una ruta de default ip route 0.0.0.0 0.0.0. 192.168.1.254 la cual apunta hacia la dirección virtual de HSRP, con esta configuración se puede asegurar la alta disponibilidad de la LAN.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión /  Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión /  Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión /  Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión /  Cambiar )

Conectando a %s

A %d blogueros les gusta esto: